Investigating Slowness into CloudSight.ai and CloudSight API
Incident Report for CloudSight API
Postmortem

An upstream issue with Amazon Web Services (AWS) Relational Database Service (RDS) caused recurring CPU spiking on our master database instance, resulting in service disruptions for both the CloudSight API and cloudsight.ai.

CloudSight engineers failed over to our hot standby database resolving the issue, yet are still working with Amazon to determine the root cause of the failure of our former master database.

Posted Mar 06, 2017 - 11:39 PST

Resolved
The failover to our backup database at AWS appears to have resolved the issue with the CloudSight API and cloudsight.ai. We are continuing to work with AWS to determine the root cause of the primary database failure and will update via a postmortem on 7 March 2017. At this time, we are resolving this issue as our services have returned to normal operation. However, we are continuing to work with AWS to determine a true root cause.
Posted Mar 05, 2017 - 23:05 PST
Monitoring
CloudSight has failed over to our backup database and CloudSight.ai and the CloudSight API are now working again. We are continuing to work with AWS to identify a root cause.
Posted Mar 05, 2017 - 22:20 PST
Investigating
We are currently investigating an apparent outage with our database hosted at AWS, causing downtime for the CloudSight API and CloudSight.ai site.
Posted Mar 05, 2017 - 21:51 PST